注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

love3400wind的blog

like

 
 
 

日志

 
 
 
 

Thrift 安装与使用  

2016-01-27 17:04:10|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
1. 下载最新的安装包
     http://thrift.apache.org/download
2. 解压安装
tar -zxvf thrift-0.9.3.tar.gz
cd thrift-0.9.3/
sudo ./configure

注:

  此处出现: configure: error: "Error: libcrypto required."  

  解决办法: sudo apt-get install libssl-dev (ubuntu)

sudo make
sudo make install
3.检查安装是否完成
thrift -version
       
4.样例
toturial.thrift 文件地址:https://git-wip-us.apache.org/repos/asf/thrift/?p=thrift.git;a=tree;f=tutorial
thrift -r --gen java   #-r 对其中的include文件也生成相应的服务代码
  评论这张
 
阅读(51)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017